Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Primer or Howto for Repair of Hybrid HF Transceiver

  1. #11

    Some progress made...

    An amateur friend and I have been investigating the problem. We discovered that the power transformer seemed okay. Also the various diode bridges seemed to test out as they should. On the HV line there are two 47uF electrolytics in series, each with a .01 cap plus a 470k resistor in parallel. A few fuses later we checked the state of the electrolytics ... and the first is a bit of a dead-short on the ohmmeter. At the same time there are spark discharges and another fuse blows!!
    I've ordered some new electros off the 'net and they will be fitted when they arrive. getting new electro was not an issue (450VW) but they are pcb type ... not the chassis-mount originals. We will probably just remove the old electros ... and mount the assembly on a 7-way tag strip screwed to the radio chassis. I am conscious of the need to maintain air-flow and NOT blocking up holes.

    More details after our next session.

    richard
    VK1RJ

  2. #12
    Administrator N8YX's Avatar
    Join Date
    Feb 2007
    Location
    Akron, OH
    Posts
    25,566
    If you're repairing a '530, have a look here (about halfway down the page):

    http://www.k4eaa.com/parts.htm

    Since the thread started I managed to acquire a TS-530SP, two TS-830S "Gold Label" units (one a project rig) and enough spare parts to make things...interesting. Look at our "Mods and Repairs" area of the site. I'm going to start a mod/upgrade thread for both rigs. There's common DNA between the two (PSU, RF, PLL and Counter Boards, final assemblies) and many of the mods destined for one will work for both.
    "Everyone wants to be an AM Gangsta until it's time to start doing AM Gangsta shit."

  3. #13
    On the recapping idea, surprisingly I see in lots of older gear the Elna capacitors are used and they hold their values pretty well even after 35 yrs or so.

    When I worked the 830S low voltage power supply section on the AF-AVR board I checked the caps and the only one I saw obviously shot because it leaked electrolyte was C9 so I replaced it.
    Others I checked showed ok so I gave up checking them all. I see the 530 also has this cap C9. Looks like maybe part of the 1st buffer after the balanced modulator if I read it right.

  4. #14
    "Island Bartender" KG4CGC's Avatar
    Join Date
    Mar 2007
    Location
    EM84ru, Easley SC
    Posts
    48,699
    KA2PTE, Hello and welcome to The Island. As is custom, your introductory tiki drink.


  5. #15
    Thanks for the welcome KG4CGC.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •